Service issues affecting SendSafely Users
Incident Report for SendSafely
Resolved
The service disruption affecting SendSafely customers has been resolved. Service was fully restored at 21:26 UTC and no additional issues have been reported.
Posted Apr 15, 2021 - 22:01 UTC
Monitoring
Service has been restored to impacted customers and we are monitoring.
Posted Apr 15, 2021 - 21:26 UTC
Identified
We have identified the cause of the availability issues affecting certain SendSafely users and are restoring service. Some customers may still be experiencing intermittent issues.
Posted Apr 15, 2021 - 21:16 UTC
Investigating
We are actively investigating a service issue impacting users in certain US hosted web portals. Updates will be provided here as more information becomes available.
Posted Apr 15, 2021 - 20:25 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US), Serverless Gateway (US)).