Service Degradation affecting SendSafely Users in the EU
Incident Report for SendSafely
Resolved
The service disruption affecting SendSafely EU customers has been resolved. Service was fully restored at 15:06 UTC and no additional issues have been reported.
Posted Sep 01, 2020 - 16:01 UTC
Monitoring
Service has been restored for EU customers. We are closely monitoring the affected systems for any further degradation.
Posted Sep 01, 2020 - 15:06 UTC
Update
We are continuing to investigate this issue.
Posted Sep 01, 2020 - 14:55 UTC
Investigating
We are currently investigating an elevated number of timeout issues affecting browser connections to EU hosted web portals. We will provide more information once we identify the root cause of the issue.
Posted Sep 01, 2020 - 14:44 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU), API (EU)).