Service Degradation affecting Website Users in US Data Center
Incident Report for SendSafely
Resolved
The service disruption affecting US customers has been resolved. Service was fully restored at 19:18 UTC and no additional issues have been reported.
Posted Apr 19, 2019 - 01:08 UTC
Monitoring
Service has been restored for all US customers. We will continue to monitor the issue to ensure that all systems remain fully operational.
Posted Apr 18, 2019 - 19:18 UTC
Identified
We have identified the issue causing service degradation affecting US customers and are working to restore service.
Posted Apr 18, 2019 - 19:10 UTC
Investigating
We are currently investigating an elevated number of timeout issues affecting browser connections to US hosted web portals. We will provide more information once we identify the root cause of the issue.
Posted Apr 18, 2019 - 18:59 UTC
This incident affected: US Data Center - N. Virginia (Public Website).