Partial outage impacting EU customers
Incident Report for SendSafely
Resolved
The service disruption affecting EU customers has been resolved. Service was fully restored at 10:10 UTC and no additional issues have been reported.
Posted Oct 28, 2019 - 10:10 UTC
Identified
We are currently investigating an elevated number of timeout issues affecting browser connections to EU hosted web portals. We will provide more information once we identify the root cause of the issue.
Posted Oct 28, 2019 - 09:38 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU)).