Service Disruption affecting SendSafely packages

Incident Report for SendSafely

Resolved

All package's have been returned to the correct state.
Posted Apr 17, 2025 - 18:10 UTC

Identified

SendSafely identified an issue with some packages that caused the packages to expire early. A fix has been released to resolve this, and the team is working to restore the correct state of packages.
Posted Apr 17, 2025 - 17:50 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US), Serverless Gateway (US)).