Service issues affecting SendSafely Users
Incident Report for SendSafely
Resolved
The service disruption affecting SendSafely customers has been resolved.
Posted Jun 18, 2021 - 01:10 UTC
Monitoring
Service has been restored to impacted customers and we are monitoring.
Posted Jun 17, 2021 - 23:30 UTC
Investigating
We are actively investigating a service issue impacting users in certain US hosted web portals. Updates will be provided here as more information becomes available.
Posted Jun 17, 2021 - 22:43 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US)).