SMS Delivery Delays
Incident Report for SendSafely
Resolved
The issue with delivery of SMS verification codes has now been resolved.
Posted Feb 26, 2021 - 16:50 UTC
Identified
SMS delivery of verification codes for some customers may be delayed due to a temporary issue with one of our SMS service providers.
We are monitoring the situation and will post updates as they become available.

Further information about this specific outage is available here: https://status.twilio.com/
Posted Feb 26, 2021 - 15:14 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU)), US Data Center - N. Virginia (Public Website, Enterprise Portals (US)), and Australia Data Center - Sydney (Enterprise Portals (AU)).