Service issues affecting SendSafely users
Incident Report for SendSafely
Resolved
The issue affecting certain backend services, including delivery of Workspace email notifications has been resolved. As a result of the issue, some users may have seen delays in notification delivery from March 4, 2022, 15:00 UTC until March 4, 2022, 19:00 UTC.
Posted Mar 04, 2022 - 19:11 UTC
Identified
SendSafely has identified an issue that is degrading the performance of certain backend services, including delivery of Workspace email notifications. We are working on a fix and expect to have these services fully restored soon.
Posted Mar 04, 2022 - 16:13 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU)), Australia Data Center - Sydney (Enterprise Portals (AU)), and US Data Center - N. Virginia (Enterprise Portals (US)).