AWS Outage affecting some SendSafely services and our upstream providers

Incident Report for SendSafely

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:19 UTC

Monitoring

Some SendSafely services are being affected by the ongoing service outage at AWS.
We are monitoring these services and will update when we know more.
Posted Oct 20, 2025 - 15:07 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU), API (EU), Serverless Gateway (EU)), US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US), Serverless Gateway (US)), Australia Data Center - Sydney (Enterprise Portals (AU), API (AU)), and Platform Integrations (All Regions).