Service Degradation affecting SendSafely Users

Incident Report for SendSafely

Resolved

Customers report a return to normal operation around 2:30 EST
Posted Mar 20, 2025 - 19:23 UTC

Monitoring

SendSafely has identified an issue that is degrading the performance of certain backend services, including delivery of SendSafely Packages.

We are working on a fix and expect to have these services fully restored soon.
Posted Mar 20, 2025 - 18:34 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US), Serverless Gateway (US)).