Workspace Email Notification Outage (US)
Incident Report for SendSafely
Resolved
The issue affecting Workspace email notifications for US Enterprise Users has been resolved. As a result of the issue, some users may have seen delays in notification delivery from Nov 19, 2021 23:20 EST until Nov 20, 2021 16:40 EST.
Posted Nov 22, 2021 - 16:43 UTC
Identified
We have identified an issue that is currently impacting Workspace email notifications for US Enterprise Users. We are working on a fix and expect to have notifications restored shortly.
Posted Nov 22, 2021 - 15:18 UTC
This incident affected: US Data Center - N. Virginia (Enterprise Portals (US)).