Service Degradation affecting SendSafely Users
Incident Report for SendSafely
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:42 UTC
Monitoring
Due to the larger AWS outage today, some customers may have experienced an elevated number of timeout issues to US hosted web portals.

We are monitoring the issue with AWS and our service.
Posted Jun 13, 2023 - 19:47 UTC
This incident affected: US Data Center - N. Virginia (API (US)).