Service issues affecting SendSafely users
Incident Report for SendSafely
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 20:15 UTC
Monitoring
SendSafely is currently investigating reports of service degradation for some US customers. We believe the issue has been resolved but will continue to monitor the situation.
Posted Jul 15, 2022 - 17:44 UTC
This incident affected: US Data Center - N. Virginia (Public Website).