Service issues affecting SendSafely users
Incident Report for SendSafely
Resolved
The issue affecting certain backend services, including delivery of Workspace email notifications has been resolved. As a result of the issue, some users may have seen delays in notification delivery from April 14, 2022, 20:05 UTC until April 14, 2022, 21:00 UTC.
Posted Apr 14, 2022 - 21:06 UTC
Identified
SendSafely has identified an issue that is degrading the performance of certain backend services, including delivery of Workspace email notifications. We are working on a fix and expect to have these services fully restored soon.
Posted Apr 14, 2022 - 20:05 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US), API (US), Serverless Gateway (US)) and Platform Integrations (All Regions).