Partial Outage impacting EU based customers
Incident Report for SendSafely
Resolved
The service disruption affecting EU customers has been resolved. No additional issues have been reported and we are continuing to monitor operations.
Posted Oct 16, 2019 - 12:35 UTC
Investigating
We are currently investigating an elevated number of timeout issues affecting browser connections to EU hosted web portals. We will provide more information once we identify the root cause of the issue.
Posted Oct 16, 2019 - 11:51 UTC
This incident affected: EU Data Center - Ireland (Enterprise Portals (EU)).