Service Degradation affecting SendSafely Users in the US
Incident Report for SendSafely
Resolved
The service degradation affecting some US customers has been resolved.
Posted Jan 13, 2021 - 20:40 UTC
Monitoring
Service has been restored to normal levels for all US customers. We will continue to monitor the issue to ensure that all systems remain fully operational.
Posted Jan 13, 2021 - 18:50 UTC
Investigating
We are currently investigating reports of service degradation on certain US based portals. We will provide more information once we identify the root cause of the issue.
Posted Jan 13, 2021 - 18:03 UTC
This incident affected: US Data Center - N. Virginia (Public Website, Enterprise Portals (US)).